Code Coverage with TeamCity

May 1, 2013 at 1:29 AM
Hello,

I'm having a problem generating the coverage report through TeamCity. I'm executing the tests through a command line build step using the chutzpah console app. The tests execute as expected, but the report is not generated.

In the build step settings, I set the working directory to be the Chutzpah console directory.
I set the executable as chutzpah.console.exe and added the /path and /coverage flags appropriately.

When I run the build, the test succeed but the coverage report does not get generated.

I tested it manually on the build server, and it worked as expected.

I even tried with an without the /teamcity flag, but I get the same result.

I searched the whole server to ensure the files were not created.

Does anyone have this working? Am I missing something here?

Thanks in advance!
Coordinator
May 1, 2013 at 3:02 AM
Thanks for making me aware of this issue. This is a bug in Chutzpah and I followed an issue (https://chutzpah.codeplex.com/workitem/115) and checked in a fix (https://chutzpah.codeplex.com/SourceControl/changeset/a4186be7a22b) for it. I will include this in a bug fix release in a couple weeks.
May 1, 2013 at 4:51 PM
OK, sounds good. I'll keep an eye out for the new release. I really like the plugins. Great work.
Oct 4, 2013 at 9:04 AM
I am running chutzpah 2.5.0 and I am experiencing this problem.

Tests are run and results are reported under the "Tests" tab in TeamCity.
The "/coverage" flag produces coverage output when I run it locally.
But when I run the exact same command inside TeamCity, no coverage report shows up. No "Code Coverage" tab (is that how it is supposed to show up?), not even any output in the Build log.

TeamCity is running on Windows Server 2008 R2